You are not logged in.

#1 2020-11-08 9:51 am

Laskov
Member
Registered: 2013-05-17
Posts: 2

The "Stop Forum Spam" service was inaccessible.

Hello i am use phpbb3.3.2 with the sfs module

Since October 27, I have in my logs the information that the service was unavailable.

has your server experienced failures?

spammers are indeed slipping through the cracks.
the last one was this night at 2:31 am (French time)

thank you

Offline

#2 2020-11-08 11:21 am

Alex Kemp
Moderator
From: Nottingham, England
Registered: 2009-12-02
Posts: 2,242
Website

Re: The "Stop Forum Spam" service was inaccessible.

If you look at the Home Page you will see there that it reports:

CURRENT API QUERIES PER SECOND = 4

which strongly suggests everything is OK.

Here is an API done just now with one of the examples drawn from the SFS API Usage page:

:~$ curl http://api.stopforumspam.org/api?ip=91.186.18.61
<response success="true">
	<type>ip</type>
	<appears>no</appears>
	<frequency>0</frequency>

Then (since that is a null-response) here is one using a recent-ish report:

~$ curl http://api.stopforumspam.org/api?ip=104.219.234.141
<response success="true">
	<type>ip</type>
	<appears>yes</appears>
	<lastseen>2020-11-03 09:12:53</lastseen>
	<frequency>1</frequency>

Then, if you still do not believe, look at the Statistics page. It takes some time to load & is huge, but you will spot "Last 500 entries" there (all currently 8 Nov 2020). Here is the api check on the top IP entry:

curl http://api.stopforumspam.org/api?ip=83.142.54.183
<response success="true">
	<type>ip</type>
	<appears>yes</appears>
	<lastseen>2020-11-08 11:05:05</lastseen>
	<frequency>1</frequency>

It seems that the problem is at your end.

Online

#3 2020-11-08 11:53 am

Laskov
Member
Registered: 2013-05-17
Posts: 2

Re: The "Stop Forum Spam" service was inaccessible.

i am just this in my log

translated from french

Anonymous     195.154.222.29     08 nov. 2020, 02:31
The "Stop Forum Spam" service was inaccessible. The following user has been authorized on the forum:
Username: ugpalelul
IP address: 195.154.222.29
Email address: <removed>

Offline

#4 2020-11-08 3:36 pm

Alex Kemp
Moderator
From: Nottingham, England
Registered: 2009-12-02
Posts: 2,242
Website

Re: The "Stop Forum Spam" service was inaccessible.

Yup, I'm fully willing to believe that you have a problem accessing SFS from your server. The issue is that all the evidence is that there is ZERO problem at SFS's end. Which means that you need to get access to your server & troubleshoot.

There is a file provided for your exact problem. See this post. Download sfsdiag.zip; extract sfsdiag.php from the ZIP & upload to your server. Visit the PHP file with your browser. Copy the results & send me a PM with those results (PM link near top of page).

PS
It is abusive to place other people's email addresses into a public forum such as this one. I've removed it.

Online

#5 2020-11-13 10:59 am

Alex Kemp
Moderator
From: Nottingham, England
Registered: 2009-12-02
Posts: 2,242
Website

Re: The "Stop Forum Spam" service was inaccessible.

No response from the OP, so I will stop actively monitoring for one now.

Online

#6 2020-11-19 6:22 am

pedigree
uıɐbɐ ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ buıʎnq ɹǝʌǝu ɯ,ı
From: New Zealand
Registered: 2008-04-16
Posts: 6,921

Re: The "Stop Forum Spam" service was inaccessible.

the queries per second on the homepage needs to come off as it was taking that data from Redis directly but now is being served directly from Cloudflare.  The 4 per second was haproxy running health tests.

The API doesnt appear to have had any downtime that Im aware of

Offline

Board footer

Powered by FluxBB

Close
Close